Coptic Fonts in Presentations Menu, Windows 8

edited December 1969 in Random Issues
Hi tasbeha community,

I know there are several threads on this matter, but they all seem slightly dated. I've followed their instructions but I am unable to see Coptic Fonts in the St. Shenouda Coptic Presentations program.

On my previous computer, and other computers running Windows Vista, I've never faced problems with the fonts or the presentations program.

Is there anybody who had managed to install and use the presentations menu with coptic fonts? If so, could you tell me if you did anything differently / how did you do it?



  • I don't have Windows 8, but I can tell you after installing Coptic Fonts Standard it didn't work for me (the past 3-4 times I've done it).
    You'll need the Athanasious fonts.
    You can get them here:
  • Epshiri,

    Last week I downloaded the presentation and I have windows 8.
    I couldn't download the coptic fonts from the st george and st shenouda website so I donloaded them from

    Then I unzipped the file and double clicked on each and pressed install.
    That did it for me.

    Let me know if this still doesnt fix it.
  • Thanks for the replies guys.

    I tried what you suggested, but unfortunately, it hasn't worked. I still have the Coptic showing up in English letters with lots of punctuation.

    But I noticed something else; the Coptic fonts now work for other applications, eg. Word or the Hymn lyrics library on this website, so I have a feeling there is something wrong with my copy of presentations menu.

    I'll try to reinstall / redownload etc. and let you know if its working.


  • Nope, didn't work unfortunately. I'm guessing there's some difference between window 7 and 8, because it always worked on my old laptop.

    During the holidays, when I return home, I'll copy and paste the presentations menu from a previous laptop, and see if that works.

  • Ah I finally got it to work! I had accidentally removed admin privileges when I first tried to install the fonts, so my PC wasn't happy, but I turned on Admin privileges and it work! So happy, because here in Hungary there are zero Coptic bookstores etc.

    Thanks for all your help ^^
Sign In or Register to comment.